Оптимальный способ расчета контрольной суммы объекта/записи регистра (CRC32, MD5, SHA1, SHA256)

Публикация № 540228

Разработка - Обработки - Универсальные обработки

контрольная сумма CRC32 MD5 SHA1 SHA256 объект изменения

19
Была задача сравнить документы в распределенных базах и пометить на выгрузку измененные. Но сравнение изменений документов методом перебора реквизитов - долгоиграющий процесс, особенно если общее количество сравниваемых данных переваливает за миллион. Был найден выход, который ускоряет процесс сравнения - расчет контрольной суммы объекта и сравнение ее с другой контрольной суммой. Скорость сравнения увеличивается во много раз.

В данной обработке приведен способ расчета контрольной суммы объекта базы данных 1С. При любом изменении данных объекта, контрольная сумма меняется. Вариант расчета контрольной суммы меняем программно. В моем случае CRC32 как раз подходит - это число.

Это может быть полезно:

  • При сравнении документов в различных базах, и не только РИБ
  • В механизме определения, изменен ли объект в журналах изменений.
  • В тех областях, о которых я еще не знаю.

Вот сам код обработки:

&НаСервере
Процедура Рассчитать()
    Объект=Ссылка.ПолучитьОбъект();
	ПолучитьХешОбъекта(Объект);
КонецПроцедуры

&НаСервере
Процедура ПолучитьХешОбъекта(Объект)
	ЗаписьXML = Новый ЗаписьXML;
	ЗаписьXML.УстановитьСтроку();
	
	СериализаторXDTO.ЗаписатьXML(ЗаписьXML,Объект);
	ДанныеСтрока=ЗаписьXML.Закрыть();
	
	Хеш=Новый ХешированиеДанных(ХешФункция.CRC32);
	Хеш.Добавить(ДанныеСтрока);
	
	Сообщить(Хеш.ХешСумма);
КонецПроцедуры

Обновлено от 03.08.2016! Если нужно получить контрольную сумму ссылочного объекта, то код выше это делает. Если нужно получить контрольную сумму записей регистров сведений, например, то лучше использовать либо наборы записей (медленный способ), либо получить данные записей запросом, и каждую запись преобразовать в структуру, и уже ее использовать для расчета контрольной суммы (быстрый способ). 

Вот примерный код:

СтрокаИзмерений="";

Для каждого Измерение Из ОбъектМетаданных.Измерения Цикл
	СтрокаИзмерений=СтрокаИзмерений+?(ПустаяСтрока(СтрокаИзмерений),Измерение.Имя,","+Измерение.Имя);
КонецЦикла;

Если ОбъектМетаданных.ПериодичностьРегистраСведений<>Метаданные.СвойстваОбъектов.ПериодичностьРегистраСведений.Непериодический Тогда
	СтрокаИзмерений=СтрокаИзмерений+?(ПустаяСтрока(СтрокаИзмерений),"Период",",Период");	 
КонецЕсли;

Для каждого Ресурс Из ОбъектМетаданных.Ресурсы Цикл
	СтрокаИзмерений=СтрокаИзмерений+?(ПустаяСтрока(СтрокаИзмерений),Ресурс.Имя,","+Ресурс.Имя);
КонецЦикла;

Для каждого Реквизит Из ОбъектМетаданных.Реквизиты Цикл
	СтрокаИзмерений=СтрокаИзмерений+?(ПустаяСтрока(СтрокаИзмерений),Реквизит.Имя,","+Реквизит.Имя);
КонецЦикла;

СтруктураДанных=Новый Структура(СтрокаИзмерений);

Выборка=РегистрыСведений[Имя].Выбрать();

Пока Выборка.Следующий() Цикл
	ЗаполнитьЗначенияСвойств(СтруктураДанных,Выборка);
	ХешСумма=ПолучитьХешОбъекта(СтруктураДанных);
КонецЦикла;

Обновлено от 09.08.2016! Как показала практика, применение способа ПолучитьОбъект() для расчета контрольной суммы не всегда оптимально (если много объектов и немного оперативной памяти) и приводит к нехватке памяти т.к. полученные объекты не удаляются из оперативной памяти, а остаются там до окончания процесса. Код вида "Объект=Неопределено"  никогда не помогает!

Был найден обходной путь, через запрос. При этом память не забивается, а скорость даже возросла.

Вот пример кода для документов:

Запрос = Новый Запрос;
Запрос.Текст ="ВЫБРАТЬ * ИЗ "+ОбъектМетаданных.ПолноеИмя(); 
				
Результат=Запрос.Выполнить();
Выборка=Результат.Выбрать();
			
СтрокаРеквизитов="";
Для каждого Колонка Из Результат.Колонки Цикл
	Если Колонка.Имя="ВерсияДанных" ИЛИ Колонка.Имя="МоментВремени" ИЛИ Колонка.Имя="Предсталение" Тогда Продолжить; КонецЕсли;
	
    СтрокаРеквизитов=СтрокаРеквизитов+?(ПустаяСтрока(СтрокаРеквизитов),"",",")+Колонка.Имя;
КонецЦикла;
			
СтруктураОбъекта=Новый Структура(СтрокаРеквизитов);
			
Пока Выборка.Следующий() Цикл
	ЗаполнитьЗначенияСвойств(СтруктураОбъекта,Выборка);
	Для каждого ТабЧасть Из ОбъектМетаданных.ТабличныеЧасти Цикл
		 СтруктураОбъекта.Вставить(ТабЧасть.Имя,Выборка[ТабЧасть.Имя].Выгрузить()); 
	КонецЦикла; 
	ХешСумма=ПолучитьХешОбъекта(СтруктураОбъекта);
КонецЦикла;

Функция ПолучитьХешОбъекта(Объект)
	ЗаписьXML = Новый ЗаписьXML;
	ЗаписьXML.УстановитьСтроку();
	
	СериализаторXDTO.ЗаписатьXML(ЗаписьXML,Объект);
	ДанныеСтрока=ЗаписьXML.Закрыть();
	
	Хеш=Новый ХешированиеДанных(ХешФункция.CRC32);
	Хеш.Добавить(ДанныеСтрока);
	
	Возврат Хеш.ХешСумма;
КонецФункции;

Возможно, так же будут вам полезны мои разработки(ТопчийДЮ):

  • //simbus.ru/public/1160676/ - Система принудительной блокировки пользователей по заданным условиям  (для платформ 8.3.6+, для ЛЮБЫХ баз)
  • //simbus.ru/public/1076549/ - САПП - система анализа на наличие проблем и/или предложений в ЛЮБЫХ базах 1С, работающих на платформе 8.3.4+
  • //simbus.ru/public/936948/ - Удобная, быстрая и функциональная подсистема обмена между узлами РИБ для УТ 11, УТ 10.3, Альфа - Авто с заменой ссылок в узлах, сравнением документов, командным управлением узлами (для платформы 8.3+)
  • //simbus.ru/public/926433/ - Выгрузка в SPOT 2D / ОРИМИ с произвольной структурой полей в файле для УТ 10.3 и не только (платформа 8.3 +)
  • //simbus.ru/public/912717/ - Гибкая система расчета зарплаты по произвольной мотивации для УНФ 1.6 и не только (Расширение + Конфигурация, платформа 8.3+)
  • //simbus.ru/public/893115/ - QR - штрихкодирование документов БЕЗ изменения печатных форм и конфигурации, с произвольными алгоритмами создания QR -кода и обработки для УТ 11 (все), ERP 2, КА 2, УТ 10.3, Розница 2.2, УНФ 1.6, БП 3
  • //simbus.ru/public/149404/ - Выгрузка-загрузка любых данных между похожими или одинаковыми конфигурациями ЛЮБЫХ баз 1С 8.1-8.3  
  • //simbus.ru/public/127859/ - Быстрый поиск дублей с четким/нечетким поиском по любому сочетанию реквизитов/реквизитов таб. частей с отбором и быстрой заменой значений в ЛЮБЫХ базах 
  • //simbus.ru/public/692252/ - Сравнение данных РИБ или обменивающихся баз с одинаковыми конфигурациями по контрольным суммам выбранных реквизитов, работающих на платформе 8.3...и выше 
  • //simbus.ru/public/201119/  - Проведение/снятие с проведения документов/очистки движений не проведенных, перезаписи ссылочных объектов с отборами для баз 1С 8.1-8.3 
  • //simbus.ru/public/621962/ - "Что? Где? Когда?" или журнал изменений с восстановлением состояния реквизитов ссылочных объектов
  • //simbus.ru/public/543417/ - Одиночная/групповая регистрация объектов/реквизитов объектов для обмена через планы обмена c отборами для ЛЮБЫХ баз 1С на 8.2-8.3 
  • //simbus.ru/public/175028/ - Удаление данных с отбором и построением дерева ссылок в базах 1С 8.1-8.3
  • //simbus.ru/public/420278/ - Загрузка иерархии номенклатуры, картинок, штрихкодов, характеристик, доп. реквизитов, цен, поступлений, номен. поставщиков из xls,xlsx,xlsm,ods,ots,csv для УТ 10.3, БП 2.0, УТ 11.1/11.2/11.3, БП 3, КА 2, ERP 2, УНФ 1.6, Розница 2.2 
  • //simbus.ru/public/427579/ - Мастер выгрузки ЛЮБЫХ данных (остатков, цен, картинок, иерархии, доп. реквизитов, характеристик, штрихкодов и т.д.) в CSV / XLS / XLSX / MXL / ODS / PDF для ЛЮБЫХ баз, работающих на платформе 8.3... и выше 
  • //simbus.ru/public/832852/ - Мониторинг цен закупки / цен продаж и наценки для Управления Торговлей 11 (все), ERP 2, КА 2, Розница 2.2
19

Скачать файлы

Наименование Файл Версия Размер
Контрольная сумма объекта
.epf 5,96Kb
01.08.16
5
.epf 5,96Kb 5 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. klinval 282 01.08.16 11:50 Сейчас в теме
Не понял в чём суть алгоритма вычисления контрольной суммы?
Или в этом и фишка: скачай обработку, посмотри код и увидишь алгоритм?
2. hakerxp 2128 01.08.16 12:02 Сейчас в теме
(1), в обработке пример расчета контрольной суммы.
3. gubanoff 46 01.08.16 13:08 Сейчас в теме
Неплохо бы в статье рассказать, как и что.
5. ditp 50 01.08.16 13:49 Сейчас в теме
(3) gubanoff,
Ой та шо там рассказывать... получаем некое описание объекта и считаем от него хеш.
Например так:

Функция ХэшДокумента(СсылкаНаДокум)
	Докум	= СсылкаНаДокум.ПолучитьОбъект();
	мтДок	= Докум.Метаданные();
	зап		= Новый ЗаписьXML;
	зап.УстановитьСтроку();
	зап.ЗаписатьНачалоЭлемента("obj");
	зап.ЗаписатьАтрибут("Дата"	, XMLСтрока(Докум.Дата));
	зап.ЗаписатьАтрибут("Номер"	, XMLСтрока(Докум.Номер));
	зап.ЗаписатьАтрибут("Пров"	, XMLСтрока(Докум.Проведен));
	зап.ЗаписатьАтрибут("Удал"	, XMLСтрока(Докум.ПометкаУдаления));
	Для Каждого рекв Из мтДок.Реквизиты Цикл
		зап.ЗаписатьАтрибут(рекв.Имя, XMLСтрока(Докум[рекв.Имя]));
	КонецЦикла;
	Для Каждого тч Из мтДок.ТабличныеЧасти Цикл
		зап.ЗаписатьНачалоЭлемента(тч.Имя);
		Для Каждого стр Из Докум[тч.Имя] Цикл
			зап.ЗаписатьНачалоЭлемента("line");
			Для Каждого рекв из тч.Реквизиты Цикл
				зап.ЗаписатьАтрибут(рекв.Имя, XMLСтрока(стр[рекв.Имя]));
			КонецЦикла;
			зап.ЗаписатьКонецЭлемента();
		КонецЦикла;
		зап.ЗаписатьКонецЭлемента();
	КонецЦикла;
	зап.ЗаписатьКонецЭлемента();

	хеш	= Новый ХешированиеДанных(ХешФункция.SHA1);
	хеш.Добавить(зап.Закрыть());
	
	Возврат хеш.ХешСумма;
КонецФункции
Показать


В примере -- документ, но для всего остального аналогично.
Вместо SHA1 можно использовать CRC, MD5 или SHA256.
6. hakerxp 2128 01.08.16 14:42 Сейчас в теме
(5), сложно у вас написано. Все намного проще. По просьбе трудящихся выкладываю текст.
7. gubanoff 46 01.08.16 16:01 Сейчас в теме
(6) ну вот, все стало понятно. Как и предполагалось, выгрузка в ХМЛ и получение хеша от файла. Эталонный подход :)
8. cleaner_it 239 03.08.16 11:45 Сейчас в теме
(6) (7) gubanoff, тогда непонятно, откуда взялся выигрыш по скорости. Для начала нужно рассчитать хеш для миллионов записей, а это тоже время.
9. hakerxp 2128 03.08.16 12:21 Сейчас в теме
(8), получение объекта или создание структуры данных записи, намного быстрее, чем перебирать реквизиты, измерения, ресурсы и искать отличия. Ну и проще. Приведу пример. У меня система сравнивает данные независимых регистров сведений в различных базах РИБ. Таблица общая получается более 1 млн. записей. Так вот - затраты на создание данной таблица по времени - около 10 мин. в одной базе и столько же в другой. Время сравнения по моему алгоритму - так же 10-15 мин. (больше времени тратится на регистрацию данных для обмена, чем на сравнение). Железо не серверное. База и СУБД пашут на простом жестком, не SSD.
4. davdykin 20 01.08.16 13:48 Сейчас в теме
Действительно, вы бы хоть принцип рассказали, я так понимаю эти алгоритмы считают хэш строк, как вы получаете эту строку
Оставьте свое сообщение

См. также

- 10 %

Система принудительной блокировки пользователей по заданным условиям (для платформ 8.3.6+, для ЛЮБЫХ баз) 2

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Платные (руб) Роли и права

Данная система предназначена контролировать выполнения тех или иных задач, контролировать технологический процесс. Гибкая система настройки, возможность блокировки по пользователям или ролям. Может работать в составе любой конфигурации. Имеется справка с описанием возможностей.

5990 руб.

29.11.2019    877    0       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Новости для пользователей 121

Отчеты и формы Пользователь Расширение (cfe) v8 1cv8.cf Абонемент ($m) Универсальные обработки

Для уведомления пользователей программных продуктов 1С о разных событиях, в них включена подсистема «Новостной центр». Это довольно удобная штука, т.к. новостные ленты сообщают о выходе обновлений, о новостях и событиях в сфере учёта. Но можно увеличить пользу от новостной подсистемы используя её локально в рамках 1С базы. Например, внутренняя служба техподдержки или внедряющая компания может через новостную ленту оповещать пользователей информационной базы об изменениях в программе, совещаниях, проведении тестирований, заполнения нужных документов или сдача отчетов к определенной дате и т.п.

1 стартмани

05.08.2019    6328    15    sapervodichka    17       

- 10 %

САПП - система слежения за заказами, долгами, резервами, остатками, оборотами и многим другим с возможностью оповещения ответственных в ЛЮБЫХ базах 1С, работающих на платформе 8.3.4+ (Конфигурация, Расширение) 9

Инструменты и обработки no Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Платные (руб) Управление бизнес-процессами (BPM) Анализ учета Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Оптовая торговля Розничная торговля Производство Управление торговлей

Данная система создавалась как универсальный механизм широкого спектра действия для анализа и обработки данных баз 1С, под кодовым названием «Система анализа проблем и предложений». Сокращенно – «САПП». Данная система умеет следить практически "за всем", уведомлять об проблемах в работе фирмы ответственных лиц, выполнять в автоматическом режиме все, что можно описать языком 1С и многое другое! Заменяет почти 80% систем для анализа данных в разрезе контрагентов товаров и не только! Имеется видео с демонстрацией части возможностей! Может работать как в составе конфигурации, так и как расширение! Обновление от 19.08.2019, версия 2.0!

19990 руб.

13.06.2019    4919    12    0       

Перенос документов и справочников ERP 2 / КА 2 / УТ 11 => БП 3.0 Промо

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Предоставляем техподдержку по всем вопросам данного обмена. Можем подключиться к вам удаленно для разбора ситуаций. Оперативно обновляем при выходе новых релизов 1С. Бесплатные обновления в течение полугода.

19700 руб.

Работа с файлами (обычная и управляемая форма) 89

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Нужно загрузить файл с клиента на сервер или же, наоборот, файл загрузить с сервера на клиент, а впридачу все это на web-клиенте, да еще и асинхронно? Нет ничего проще, читай далее, как это сделать!

1 стартмани

10.06.2019    8238    59    Xershi    44       

Быстрый запрос 42

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    7567    15    mkalimulin    28       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Электронная таблица в 1С средствами табличного документа 68

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Функционал электронной таблицы для программ на платформе 1С реализован на основе табличного документа. Функционал реализован в виде обработки (тонкий клиент). В формулах электронной таблицы можно использовать любые языковые конструкции, процедуры и функции 1С, ссылки на другие ячейки электронной таблицы. Допустимо обращаться к ячейкам электронной таблицы по имени именованной области. В случае использования в формулах электронной таблицы данных из самой таблицы пересчет зависимых ячеек с формулами производится автоматически. Электронную таблицу можно сохранить в файл формата xml.

1 стартмани

23.04.2019    7263    46    user706545_kseg1971    36       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 563

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    31511    283    bonv    117       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX 172

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    16074    66    Synoecium    37       

Редактор объектов информационной базы 8.3 44

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.37 от 14.12.2019

2 стартмани

23.01.2019    12192    157    ROL32    28       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Сравнение pdf-файлов актов сверки 1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП2.0 Россия БУ Дебиторская и кредиторская задолженность Абонемент ($m) Универсальные обработки

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    7781    4    Torin99    2       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Обнуление остатков регистров бухгалтерии и накопления 42

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m) Универсальные обработки Чистка базы

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    11598    186    morozov.sv    30       

- 10 %

Удобная, быстрая и функциональная подсистема обмена между узлами РИБ для УТ 11, УТ 10.3, Альфа - Авто с заменой ссылок в узлах, сравнением документов, командным управлением узлами (для платформы 8.3+) 1

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Платные (руб) Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8

Посвящается всем, кто намучился с обменом между базами РИБ в Альфа-Авто версии 4, версии 5… или со штатным неудобным, медленным обменом в базах Управление торговлей 11, Управление торговлей 10.3, или в базах, построенных на БСП! Всем тем, у кого нормально не происходил обмен изменениями конфигурации, терялись данные при обмене… Тем, кто не мог выполнить обмен в ручном режиме сразу с несколькими узлами… Тем, кто не мог спокойно изменить данные узла, не прибегая к сторонним обработкам… Всем тем, кто не мог удалить дубли элементов одним махом во всех узлах РИБ… А так же тем, кто не имел возможности сравнить документы в пределах узлов на предмет отличий их от имеющихся в ЦБ и установить, например, факт мошенничества или ошибок при обмене…

24990 руб.

06.11.2018    6197    4    0       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Навигатор по конфигурации базы 1С 8.3 108

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРНавигаторУпр) для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Небольшой набор сервисных функций для повседневной работы. Для программистов и пользователей. Платформа 8.3, управляемые формы. Версия 1.1.0.47 от 25.11.2019

3 стартмани

28.10.2018    18598    202    ROL32    47       

- 10 %

Выгрузка в SPOT 2D / ОРИМИ с произвольной структурой полей в файле для УТ 10.3 и не только (платформа 8.3 +) 5

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::УФ УТ10 УУ Оптовая торговля Платные (руб) Внешние источники данных

Данная система предназначена всем, кому нужно выгружать данные в SPOT 2D или в ОРИМИ. Позволяет гибко настроить получение данных для каждого поля файла и файла выгрузки в целом. Имеет отборы по организации, складу, и папкам номенклатуры. Есть возможность выгружать данные как вручную, с выбором конкретного файла, за конкретный период, так и в автоматическом режиме в указанное вами время. Выгрузка может выполняться в файл или через http напрямую. Имеется подробная справка по настройке, а также примеры запросов для приведенных в примерах файлов выгрузки.

7990 руб.

19.10.2018    7166    24    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

- 10 %

Гибкая система расчета зарплаты по произвольной мотивации для УНФ 1.6, КА 2.4 и не только (Конфигурация (ядро) + Расширение, платформа 8.3+) 18

Инструменты и обработки Бухгалтер Расширение (cfe) v8 УНФ БУ УУ Зарплата Платные (руб) Рабочее место

Данная система разрабатывалась как альтернатива штатным средствам расчета зарплаты, а именно премиальной части. Создана для УНФ 1.6, но может использоваться с небольшими доработками в других конфигурациях. Настройки все выполняются в пользовательском режиме. Есть возможность создать произвольные запросы для получения данных, полученные данные можно обработать с помощью задания дополнительных критериев, просуммировать. Задать порядок расчета, использовать рассчитанные ранее данные в следующем расчете и обработке результата. А так же можно создать для каждой должности свой план расчета и использовать их в документе "Начисления зарплаты". Система выполнена в виде расширения и конфигурации. Имеется полная справка, которую можно скачать в данной публикации ниже. А так же имеются примеры настройки системы. (Обновление от 05.02.2019, версия 2.0)

4990 руб.

28.09.2018    9297    49    0       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

- 10 %

QR - штрихкодирование документов БЕЗ изменения печатных форм и конфигурации, с произвольными алгоритмами создания QR -кода и обработки для УТ 11 (все), ERP 2, КА 2, УТ 10.3, Розница 2.2, УНФ 1.6, БП 3 31

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 УТ10 Розница УНФ ERP2 БП3.0 УТ11 КА2 УУ Платные (руб) Обработка документов Поиск данных Сканер штрих-кода

Все знают, что в QR - код можно закодировать большое количество информации, но не все знают что это можно использовать в автоматизации бизнеса, в частности в плане документооборота. Представьте, что есть система, которая НЕ ТРЕБУЕТ изменения конфигурации, НЕ ТРЕБУЕТ изменения ни одной печатной формы для добавления QR-кода, включая внешние, НЕ ХРАНИТ данные штрихкодов и их связь, от чего база не "пухнет", ИМЕЕТ возможность закодировать в QR-коде произвольные данные параметров для последующей обработки полученных данных, УМЕЕТ обработать считанный QR-код как ВЫ захотите - например, ОТКРЫТЬ документ, СОЗДАТЬ документ любого вида по входным параметрам, ОТОБРАТЬ из документа определенные данные и перенести их в другой документ, ОТКРЫТЬ отобранные данные по данным QR-кода в виде таблицы для сверки данных и прочее. А так же ИМЕЕТ удобный интерфейс, ХРАНИТ историю операций в обход базы для каждого пользователя в отдельности и УМЕЕТ работать с 2D - сканерами в режиме клавиатуры и эмуляции USB COM. А так же автоматически распознавать отсканированные печатные формы и выполнять заданные произвольные алгоритмы! (Обновление от 16.01.2019, версия 2.00)

5990 руб.

26.08.2018    13539    72    2       

- 10 %

Мониторинг цен закупки / цен продаж и наценки для Управления Торговлей 11 (все), ERP 2, КА 2, Розница 2.2, УНФ 1.6 48

Инструменты и обработки Бизнес-аналитик Пользователь Внешняя обработка (ert,epf) v8 v8::ОУ Розница УНФ ERP2 УТ11 КА2 УУ Ценообразование, анализ цен Платные (руб) Ценообразование, прайсы Обработка документов

Обработка позволяет увидеть цены закупки и цены продажи, и проанализировать наценку, для того чтоб не уйти в "минус". Обработка динамически формирует таблицу с ценами в зависимости от выбранных видов цен и прочих отборов в разрезе и характеристик тоже. Так же можно сразу создать документ установки цен с указанными ценами. (Обновление от 01.12.2018, версия 1.11)

2990 руб.

18.05.2018    14214    16       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Просмотр, изменение реквизитов объекта. Сравнение двух одинаковых объектов метаданных ИБ 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Показывает реквизиты объекта (ов) или сравнивает два одинаковых объекта конфигурации справочники, документы.

1 стартмани

26.04.2018    10312    18    Vin_Tik    0       

Групповая обработка прикрепленных файлов 61

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Абонемент ($m) Универсальные обработки

Кому не знакомы авралы в бухгалтерии, когда налоговая требует представить копии всех документов за два-три года? Кто не получал сюрпризов в виде отсутствия документов, когда завтра их нужно уже представлять проверяющим? 1С предлагает прикрепление и хранение копий документов (в том числе со сканера) в базе, а данная обработка решает вопрос их быстрой подборки, сортировки и выгрузки, а также быстрого и эффективного контроля наличия или отсутствия документов в базе с формированием реестров как выгруженных, так и отсутствующих документов. В настоящий момент обработка бесплатна, в дальнейшем планируется платная версия с расширенными возможностями. Скажите решительное "Нет" авралам в бухгалтерии и штрафам за несвоевременное представление документов!

4 стартмани

16.04.2018    10093    27    Krasnyj    0       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

Построение маршрута доставки с расчётом расстояния для любой базы УФ 57

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    21950    36    KorotkovRV    16       

Навигация по функциональным опциям типовых конфигураций 130

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Пользователю системы

Из релиза в релиз разделы и функциональные опции меняют своё местоположение. Вкупе с многостраничными формами настроек поиск нужной настройки становится испытанием для терпеливых. Я нашел такое решение.

1 стартмани

30.01.2018    17457    75    kuzyara    12       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Проверка орфографии средствами Yandex Speller 78

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Проверка орфографии средствами Yandex Speller с опциями и коррекцией ошибок. Возможность вызова как с сервера, так и с клиента (с последующим исправлением).

1 стартмани

09.11.2017    14695    50    🅵🅾️🆇    38       

- 10 %

Сравнение ЛЮБЫХ данных обменивающихся баз с одинаковыми/похожими конфигурациями по контрольным суммам выбранных реквизитов, работающих на платформе 8.3... и выше 17

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Платные (руб) Обмен через XML Перенос данных из 1C8 в 1C8 Распределенная БД (УРИБ, УРБД)

Данная обработка позволит Вам легко и просто, а главное - быстро, выполнить сравнение данных между базами РИБ или одинаковых объектов конфигураций по контрольным суммам выбранных объектов баз 1С, работающих на платформах 8.3 и выше. Удобный и понятный интерфейс в виде "мастера". Высокая скорость сравнения достигается за счет специального алгоритма расчета контрольной суммы объекта/записи и сравнения по данным суммам объектов 2х баз через файл. Имеется возможность выбора реквизитов, по которым система будет сравнивать объекты. Из плюсов так же можно отнести - выбор объектов конфигурации для КАЖДОГО узла в отдельности с индивидуальным отбором для каждого объекта конфигурации, работа с FTP, сохранение или загрузка настроек, сохранение или загрузка результата сравнения, регистрация на обмен объекта и его движений, его реквизитов и многое другое. Ну и конечно понятная подробная справка, которую можно скачать бесплатно для ознакомления. (Обновление от 20.03.2019, версия 1.5)

7990 руб.

27.10.2017    18428    27    6