Внешняя компонента печати PDF (Native Win 32/64)

Публикация № 856112

Разработка - Разработка внешних компонент

обработка печать PDF

17
Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

Общее описание

Отлично подходит для печати прикрепленных файлов в формате PDF, а также печатных форм, есть возможность загрузки PDF из двоичных данных, позволяет показывать диалог печати с установкой диапазона страниц и количества копий или же задавать принтер и диапазон страниц непосредственно в вызове.

Для подключения компоненты используются стандартные методы УстановитьВнешнююКомпоненту() на Клиенте в синхронном режиме, ПодключитьВнешнююКомпоненту() на Сервере или на Клиенте в синхронном режиме, и НачатьУстановкуВнешнейКомпоненты() и НачатьПодключениеВнешнейКомпоненты() на Клиенте в асинхронном режиме вызовов.

Перед началом работы на стороне клиента в асинхронном режиме необходимо вызвать установку компоненты:

НачатьУстановкуВнешнейКомпоненты(ОбработчикРезультата, АдресКомпоненты);

Далее необходимо ее подключить и можно вызывать ее методы:

НачатьПодключениеВнешнейКомпоненты(ОбработчикРезультата, АдресКомпоненты, "PrintPDF");

Примерный код использования компоненты на стороне Клиента в асинхронном режиме может выглядеть так:

Перем мКомпонента;

&НаКлиенте
Процедура Печать(Команда)	
	
	Если мКомпонента = Неопределено Тогда
		УстановитьКомпоненту(
			Новый ОписаниеОповещения("ПечатьПродолжение", ЭтотОбъект));
		Возврат;
	КонецЕсли;	
	
	ПечатьПродолжение(Истина, Неопределено);	
		
КонецПроцедуры	

&НаКлиенте
Процедура ПечатьПродолжение(КомпонентаПодключена, ДополнительныеПараметры) Экспорт	
	
	Если НЕ КомпонентаПодключена Тогда
		Возврат;
	КонецЕсли;
	
	Если мКомпонента = Неопределено Тогда
		мКомпонента = Новый("AddIn.PrintPDF.PrintPDFAddInExtension");
	КонецЕсли;		
		
	мКомпонента.НачатьВызовПечать(Новый ОписаниеОповещения("ПечатьЗавершение", ЭтотОбъект), 
		ИмяФайла, Описание, ПоказыватьДиалогПечати, Принтер, Пароль, Страницы);
	
КонецПроцедуры
	
&НаКлиенте
Процедура ПечатьЗавершение(РезультатВызова, ПараметрыВызова, ДополнительныеПараметры) Экспорт	
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьКомпоненту(ОбработчикРезультата) Экспорт
			
	Обработчик = Новый ОписаниеОповещения("УстановитьКомпонентуЗавершение", ЭтотОбъект, ОбработчикРезультата);
	
	НачатьУстановкуВнешнейКомпоненты(Обработчик, АдресКомпоненты);
	
КонецПроцедуры

&НаКлиенте
Процедура УстановитьКомпонентуЗавершение(ОбработчикРезультата) Экспорт
	
	НачатьПодключениеВнешнейКомпоненты(ОбработчикРезультата, АдресКомпоненты, "PrintPDF");		
	
КонецПроцедуры

Есть возможность вызова компоненты из внешней обработки, чтобы не снимать типовую конфигурацию с поддержки, рабочий код использования компоненты представлен в обработке TestPrintPDF.epf (в обработке отсутствует компонента, поэтому ее нужно загрузить в макет после покупки).

Компонента работает как на x86, так и x86_64 платформах, в режиме Сервера, Тонкого клиента и Веб-клиента (для браузеров Firefox и Chrome), распространяется в виде пакетного файла, который содержит в себе все версии компоненты.

Протестировано на всех версиях платформы, начиная от 8.2.19.130.

Методы:

Печать / Print - основной и пока единственный метод, отправляет файл на печать

Может вызываться как с передачей имени файла, так и двоичных данных

Параметры при передаче имени файла:
ПутьКФайлу - обязательный, тип "Строка", полный путь к файлу PDF
Описание - обязательный, тип "Строка", описание задания печати
ПоказыватьДиалогПечати - необязательный, тип "Булево", определяет показывать диалог печати или нет, значение по умолчанию - Ложь
ИмяПринтера - необязательный, тип "Строка", имя принтера, на который будет отправлен документ, если не определен, то печать осуществляется на принтер, установленный по умолчанию в система
Пароль - необязательный, тип "Строка", пароль для чтения защищенного PDF-файла
Страницы - необязательный, тип "Строка", диапазоны страниц для печати, разделенные запятыми (например "1,5,6", или "1-3,7-9", или "1,3-5")
Автоповорот - необязательный, тип "Булево"

Параметры при передаче двоичных данных:
Данные - обязательный, тип "ДвоичныеДанные", двоичные данные файла PDF
Описание - обязательный, тип "Строка", описание задания печати
ПоказыватьДиалогПечати - необязательный, тип "Булево", определяет показывать диалог печати или нет, значение по умолчанию - Ложь
ИмяПринтера - необязательный, тип "Строка", имя принтера, на который будет отправлен документ, если не определен, то печать осуществляется на принтер, установленный по умолчанию в система
Пароль - необязательный, тип "Строка", пароль для чтения защищенного PDF-файла
Страницы - необязательный, тип "Строка", диапазоны страниц для печати, разделенные запятыми (например "1,5,6", или "1-3,7-9", или "1,3-5"
Автоповорот - необязательный, тип "Булево"

 

Важно

В асинхронном режиме вызовы методов должны выполняться через НачатьВызов, например:

Компонента.НачатьВызовПечать(Новый ОписаниеОповещения("ПечатьЗавершение", ЭтотОбъект), 
		ИмяФайла, Описание, ПоказыватьДиалогПечати, Принтер, Пароль, Страницы);

 

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

17

Скачать файлы

Наименование Файл Версия Размер
Тестовая обработка (УФ)
.epf 9,80Kb
25.07.18
48
.epf 9,80Kb 48 Скачать бесплатно
01.08.2019
1.3 12 1000 руб.

Моментальная
доставка

01.08.2019
0 1000 руб.

Внешняя компонента печати PDF (Native Win 32/64)
Добрый день! Компонента может печатать на Сервере?
4
1

Новый вопрос

E-mail*
Тема (вопрос)*

Специальные предложения

См. также

Внешняя компонента ExtMessage 3

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Windows Платные (руб) Разработка внешних компонент Внешние источники данных Интеграция

Передача сообщений между двумя 1С, или между 1С и другими приложениями. Может использоваться как альтернатива COM-соединению.

2500 руб.

10.10.2019    1021    0       

Внешняя компонента клиента SSH / SCP (Native API) 5

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Платные (руб) Разработка внешних компонент

Внешняя компонента, выполненная по технологии NativeAPI, для взаимодействия с удаленными серверами по протоколу SSH, обмена файлами по протоколу SCP и возможностью перенаправления портов через SSH туннель.

5000 руб.

18.06.2019    1899    12    0       

Компонента для 1С, принимающая вес с железнодорожных, автомобильных, крановых весов 3

Инструменты и обработки Программист Пользователь Компонента, плагин (dll, vbs,..) v7.7 v8 Транспорт, автопарки, такси Россия Windows Платные (руб) Разработка внешних компонент

Программа "Компонента приёма веса для 1С, версия 3.0" позволяет принимать и заносить вес с весов непосредственно в программу "1С" - то есть, прием веса осуществляется целиком и полностью из программы "1С".

22000 руб.

09.04.2019    2355    0       

Пакетная печать в строго заданном порядке 6

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Пакетная печать

В силу различных особенностей ПО, ОС, драйверов и т.д. порядок печати документов не всегда совпадает с порядком их отправки на печать. Данный метод позволяет всегда получать на выходе нужный порядок документов.

19.09.2018    5284    crazycat    17       

Внешняя компонента для подключения 1С к телефонии Asterisk 20

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Россия Windows Платные (руб) Разработка внешних компонент Телефония, SIP

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод звонков, набор телефона и т. д.)

1000 руб.

04.05.2018    14010    28    12       

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями в ФЗ от 01/07/19 80

Инструменты и обработки Системный администратор Программист Бухгалтер Архив с данными v7.7 v8 1cv8.cf 1cv7.md Россия БУ УУ Windows Кассовые операции Платные (руб) Инструментарий разработчика Разработка внешних компонент WEB ККМ

FR_ATOL_SHTRIH.EXE встраивается в SYSTRAY (в правом нижнем углу, там где часы) и следит за появлением обычного текстового файла, в котором перечислено, какие операции необходимо осуществить с ККТ - напечатать чек (нал/безнал), снять Z-отчет, осуществить выемку денег, сделать возврат и т.д. Такой механизм позволяет использовать комплект для WEB сайтов, для нетиповых или сильно измененных 1с7 или 1с8. Для любых программ, которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые к использованию обработки для 1с8: УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1С7.7:ТиС документ Реализация ТМЦ,Печать из ПКО, Бух4.5, Бух1.3 . Код на 1с открыт - используйте обработки комплекта, как шаблоны для своих программ. Подключать ККМ к 1С не надо! Более 300 внедрений на ККМ Штрих и Атол. Некоторые из покупателей реализовали работу с ККМ даже из Excel и Axapta.

1000 руб.

31.07.2017    44722    345    359       

Медиадисплей. Рекламный информационный монитор для покупателя. 23

Инструменты и обработки Программист Пользователь Приложение (exe) v8 КА1 УТ10 Розница УНФ ERP2 БП3.0 УТ11 КА2 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Реклама, PR и маркетинг УУ Windows Розничная торговля Платные (руб) Разработка внешних компонент POS терминал Рабочее место Мобильная разработка

Монитор покупателя может отображать текущую покупку на кассовом месте, показывать видеорекламу, баннеры, во время простоя разворачивать рекламу на весь экран. Можно использовать в качестве графического меню-борда в кафе и видеовывески. Управление выводом на телевизор через hdmi-приставку на базе Windows или Android. В качестве устройства отображения можно использовать Android-планшеты, фоторамки с Android, монитор любого Windows-компьютера, доступного по сети. Настраивается ЛЮБОЙ ДИЗАЙН экрана!

5000 руб.

30.05.2017    24340    400    19       

Сервер ККМ (54-ФЗ, быстрая печать чеков из терминального сеанса, печать с нескольких ПК) 124

Инструменты и обработки Системный администратор Программист Пользователь Приложение (exe) v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Windows Кассовые операции Розничная торговля Платные (руб) ККМ Разработка внешних компонент POS терминал Фискальный регистратор

"Сервер ККМ" позволяет приложениям работать с фискальными регистраторами из терминального сеанса Windows по локальной сети или интернет, организовать печать на одном ККМ с нескольких рабочих мест. Поддержка драйверов Атол, Штрих и VikiPrint. Поддержка 54-ФЗ. Подключается к 1С Торговля и склад 7.7, 1С:УТ 10/11, 1С:УНФ, 1С:Розница 1/2, 1С:БП 2/3, 1С КА 1/2., 1С:ERP, УПП

5000 руб.

02.09.2016    69774    2343    128       

Компонента NativeAPI 1С для массового распознавания и печати штрих-кодов 41

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Россия Windows Платные (руб) Разработка внешних компонент

Программная компонента в формате NativeAPI 1C-предприятия (не ниже 8.2) предназначена для массового распознавания штрих-кодов из файлов на жестком диске, или загруженных в память компьютера из базы данных или любым другим способом, а также отображения штрих-кодов без использования дополнительных компонентов на стороне клиента.

8000 руб.

15.08.2016    27746    105    35       

Внешняя компонента для генерации QR-кодов в 1С для ЕГАИС 2

Инструменты и обработки Системный администратор Программист Архив с данными v7.7 v8 1cv8.cf 1cv7.md Розничная и сетевая торговля (FMCG) Платные (руб) Разработка внешних компонент

«Автоматизация бизнеса: QR-код» – внешняя компонента для «1С:Предприятие», которая позволяет генерировать QR-код в формате BMP. Актуальна для тех, кто обязан подключиться к ЕГАИС в части продаж. Благодаря этой компоненте, вы сможете печатать QR-код на фискальных регистраторах, которые не поддерживают генерацию QR-кодов.

4000 руб.

16.06.2016    19841    51    1       

SIP софтфон для 1С:Предприятия 11

Инструменты и обработки no Приложение (exe) v8 Windows Платные (руб) Разработка внешних компонент Телефония, SIP

SIP софтфон для 1С:Предприятия — это программный телефон, реализованный по технологии ActiveX с возможностью интеграции с 1С версии 8.x. SIP софтфон является самостоятельным приложением, и его работа не зависит от работоспособности 1С:Предприятия. Таким образом, при временной неработоспособности 1С вы остаетесь на связи для своих клиентов. По входящему звонку вы можете осуществить поиск контрагента в базе, передать на панель вызовов софтфона необходимую информацию, создать новый документ, автоматически заполнив реквизит «Контрагент» или осуществить исходящий звонок непосредственно из 1С, не разворачивая окно софтфона. Единственное ограничение — это ваша фантазия. SIP софтфон работает по протоколу SIP 2.0 и совместим со всеми АТС, поддерживающими данный протокол.

2800 руб.

13.08.2015    28230    318    12       

Кроcсплатформенное динамическое выполнение кода .NET (C#) из 1С:Предприятие 4

Инструменты и обработки Программист Подсистема v8 1cv8.cf Платные (руб) Разработка внешних компонент

Библиотека позволяет динамически выполнять фрагменты кода, написанные на C# аналогично функции Выполнить в 1С:Предприятие, на компьютерах под управлением ОС Windows и Linux. Имеется возможность передавать параметры, возвращать результаты выполнения, загружать сборки .NET, а также отслеживать ошибки выполнения кода C#. Библиотека оформлена в виде подсистемы.

2500 руб.

02.06.2015    14637    30    11       

V82Jpeg - Компонента обработки изображений 2

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Платные (руб) Разработка внешних компонент

Работа с изображениями: преобразование форматов, сжатие/расширение, простейшие операции редактирования, чтение атрибутов фотографий и их классификация по параметрам съемки - все это только из 1С без установки дополнительного софта.

10000 руб.

26.02.2015    13243    43    10       

Работа с PowerShell из 1С 35

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Платные (руб) Разработка внешних компонент

Библиотека позволяет выполнять фрагменты кода PowerShell из 1С, аналогично встроенной процедуре Выполнить. Имеется возможность передавать параметры, возвращать результаты выполнения, генерировать внешние события, а также отслеживать ошибки выполнения кода PowerShell. Библиотека оформлена в виде подсистемы.

2000 руб.

28.04.2014    34681    38       

Мастер создания внешних компонент 1С (технология COM) для DELPHI 6/7/8/2005/2006/2007/2008/2010/XE/XE2/XE3 59

Инструменты и обработки Программист Приложение (exe) v8 Windows Платные (руб) Разработка внешних компонент

Средство для сверхбыстрой разработки внешних компонент 1С:Предприятия 7.7 и 8 по технологии COM на всех версиях DELPHI, начиная с 6.

1000 руб.

28.03.2013    38962    13       

GGraphics - внешняя компонента для работы с картинками jpg (jpeg), png, bmp, gif, tif 157

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Платные (руб) Разработка внешних компонент

Позволяет автоматизировать работу с картинками. С помощью компоненты можно измерять размер изображений, поворачивать их, наносить водяные знаки, конвертировать из одного формата в другой. Будет очень полезна для интернет-магазинов и всех, кому постоянно требуется работать с различными графическими форматами. Выполнена по технологии NativeAPI. Работает с форматами: jpg (jpeg), png, bmp, gif, tif

2000 руб.

02.09.2010    49922    206    193